Tag Archive: Google-bot crawl error

Duplicate Domain Name in URL Google Crawl Errors

July 15, 2011

I came across a very annoying error while reviewing a client’s site through Google Webmaster Tools the other day. For some reason, Google was reporting crawl errors while trying to find a page that contained my domain name twice!!

Welcome, my friend, to malformed links. Essentially, a malformed link is a link that has been inserted improperly, or isn’t a full link. You can find these in your code, in your blog posts, forums, whatever. Google will crawl your site, and if it comes across one of these malformed links, it won’t be able to tell what do with it.

For example, if your linked is placed like this :

Then Google-bots will not recognize that this is a separate URL outside of your site. Without the “http://“, Google ( and other search engines ) considers whatever is inside that link as just a file name that is inside your root directory. Thus, it comes up with a link that is :

http://www.yoursite.com/blog/www.yoursite.com

It’s imperative that you make sure all of your links are inserted properly. It has to contain the ENTIRE URL in order to be indexed and function properly.

You may say to yourself, “I have a TON of these links!” or “How can I find them all?”

Well thanks to a Google Forum Support Member, Webado, I’ve got the answer to those questions! Let me introduce you to Xenu.

Xenu is software that will search through your entire site and find broken/malformed links. It works almost flawlessly, and the software size is only 1MB!! Perfect for people coming across this problem!

Hopefully this fixes your issue. If not… search elsewhere :p